воскресенье, 1 июля 2012 г.

Ошибка Visual C++: error MSB8009: .NET Framework 2.0/3.0/3.5 задают набор инструментов платформы v90. Убедитесь, что на данной машине выполнена установка Visual Studio 2008

При компиляции проекта Windows Forms с .NET 3.5 на Visual Studio 2010 появляется ошибка:
В русской версии:
"C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Microsoft.CppBuild.targets(292,5): error MSB8009: .NET Framework 2.0/3.0/3.5 задают набор инструментов платформы v90. Убедитесь, что на данной машине выполнена установка Visual Studio 2008."

В английской версии:
"C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Microsoft.CppBuild.targets(292,5): error MSB8009: .NET Framework 2.0/3.0/3.5 target the v90 platform toolset. Please make sure that Visual Studio 2008 is installed on the machine".
Решается следующим образом:

В русской версии в IDE в "Обозревателе решений" > правой кнопкой на проекте и выбираем в " Свойства" > В дереве свойств слева "Свойства конфигурации" > узел "Общие". Затем на форме изменяем свойство "Набор инструментов платформы" с v90 на v100.


В IDE в "Solution Explorer" > правой кнопкой на проекте и выбираем в " Properties" > В дереве свойств слева "Configuration Properties" > узел "General". Затем на форме изменяем свойство "Platform Toolset" с v90 на v100.

Потом перекомпилируем проект.

2 комментария: